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LAB 17 - Creating Plan Sheets

Creating Plan and Profile sheets is a repetitive and time consuming process. InRoads has automated this 
process. This lab demonstrates P and P sheet creation and editing with the InRoads Plan and Profile Generator 
command.

Chapter Objectives: 

 Input data for the initial P and P sheet creation

 Prepare the seed files for the Plan and Profile Generator command

 Edit sheet extents and recreate sheets

 Move reference files within the sheet border

 Add a model file to a single sheet

Before beginning this lab, verify that the following files are loaded:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345DES.ird

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

 C:\Projects\12345\Design\InRoads\12345DES.dtm

 C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Prof.dgn

 C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Model.dgn

Note: The 12345DES_Model.dgn file should have feature data displayed from previous 
labs. If this file is empty or if data not appropriate for plan sheets is near the SH 86 
alignment, then all data in the file should be deleted and surface features from the 
12345DES.dtm and the SH 86 alignment should be displayed prior to working the 
lab.

Lab 17.1 - Creating 100 Scale P and P Sheets

This lab illustrates the user input required to produce an initial set of P and P sheets.

1. Open the C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Prof.dgn file 
in MicroStation.

The step below sets the scale factor so that text displayed by InRoads will be the proper size for 
a 100 scale plan set.
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2. Select File > Project Options and <D> the Factors tab and set the scale factors to 100 
for the Text Scale Factor and the Cell Scale Factor. Set the Linestyle Scale Factor to 1. 
This can also be done from the Global Scale Factors dialog box.

3. <D> Apply then Close.

Preferences are predefined menu settings that are used to set up the dialog box for a particular 
style of plan sheet. In this case, a 100 scale plan and profile sheet with a 2 times vertical 
exaggeration is desired. The steps below select the desired preference.

4. From the InRoads menu bar, select Drafting > Plan and Profile Generator. The Plan 
and Profile Generator dialog box is displayed.

5. On the Plan and Profile Generator Main tab, <D> the Preferences button. This displays 
the Preferences dialog box.

6. From the Preferences dialog box, highlight 100 Scale P&P (2x Vert).

7. <D> Load.
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8. <D> Close. This dismisses the Preferences dialog box.

Preferences do not make all of the desired changes to menu settings, in particular those that are 
project specific. The steps below make the project specific changes to the menu settings.   

9. Back on the Main tab, in the Station Limits area, key in 204+00.00 for the Start station.

10. key in 260+00.00 for the Stop station.

Reference files that make up the plan portion of the sheets are selected from the Plan Controls 
tab. The following steps are used to select the desired files.
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11. <D> the Plan Controls tab.

12. <D> the Model Files button. This displays the Open Model File dialog box.

13. Highlight the C:\Projects\12345\Design\Drawings\Reference 
Files\12345DES_Model.dgn file.

14. <D> Open. The file is added to the Model Files list and the Open Model File dialog box is 
dismissed.

15. <D> the Model Files button. This displays the Open Model File dialog box.

16. Highlight the C:\Projects\12345\ROW_Survey\Drawings\Reference 
Files\12345SURV_Topo.dgn file.

17. <D> Open. The illustration below shows the Plan Controls tab with the two files added.
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The Profile controls tab determines how the profiles will be displayed. Most of the settings are 
by the selected preference, however, it is a good idea to check the Surface area and make sure it 
is set up as desired. In this exercise, only the existing ground is to be displayed in the profile so 
it is the only one toggled on. The highlighted surface is used to determine where elevation 
shifts occur. Because the existing ground is the only surface displayed, it is also used to 
determine elevation shifts. 

18. <D> the Profile Controls tab.

19. Select SH 86 V as the Vertical Alignment.

20. Select 12345DES as the Corridor.

21. In the Surface area, toggle off all surfaces except 12345 existing ground.

22. Verify that the surface 12345 existing ground is toggled on and highlighted. 

23. <D> the None button to the right of the Super Control Lines list box to deselect all of 
the superelevation control lines.

The illustration below shows the tab as completed.

With the exception of the Host File, the Sheet Layout tab is set by the preference selected. The 
Host File is the base name that the finished sheets will be called. The host file name is 
incremented for each sheet created so that they will all have a unique name. In the steps below, 
the host file name is entered.

24. <D> the Sheet Layout tab.

25. <D> in the Host File field, then <D> the  button. This displays the Save As dialog box.
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26.  In the Save As dialog box, navigate to the C:\Projects\12345\Design\Drawings\ folder.

27. In the File Name field, key in 12345DES_PnP.dgn.

28. <D> the Save button. This dismisses the Save As dialog box adds the file name to the Host 
file field.

The Border and Title tab identifies the cell used for the sheet border. This tab should be 
checked to ensure that the proper border cell is being used. Also check to make sure that all of 
the toggles in the symbology area are turned off. If left on, erroneous data could be displayed 
on the sheets.

29. <D> the Border and Title tab.

30. Verify that the Sheet_Design-Sheet cell is selected for the cell Name.
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31. Verify that all of the check boxes in the Symbology area are toggled off.

32. <D> the Apply button.

33. <D> in the MicroStation view window.

The command creates a profile for each sheet (there are 5 sheets in this project) and then 
creates the sheets, each as a separate dgn file. The last sheet is shown below.
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The plan and Profile generator offers an easy to move between generated sheets. Using the 
Sheet Index tab, sheets can be opened in without having to navigate through the MicroStation 
menus. Use the steps below to review the other sheets.

34. <D> the Sheet Index tab.

35. Highlight sheet 1 in the Sheet Index list.

36. <D> the Show Sheet button.

37. Repeat steps 31 and 32 for the remaining sheets.

Lab 17.2 - Creating 50 Scale P and P Sheets

To switch from 100 scale sheets to 50 scale requires some additional setting changes. Most of 
these are handled through the preferences, however the Annotation Scale for the profile and 
seed host file and the InRoads Scale Factors must be set before executing the command. This 
insures that the correct annotation scale is applied to each sheet.

The (MicroStation) annotation scale does not affect graphic elements displayed by InRoads but 
it will affect elements added with MicroStation commands.

This lab uses the same data as above to create a set of 50 scale P&P sheets.

In the steps below, the model properties are changed in the 3D-Seed_CDOT.dgn (seed host 
file). This will ensure that each P and P sheet created will have the proper annotation scale for 
the project.

1. Using the MicroStation menu bar, open the:
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C:\Workspace\Workspace-CDOT_XM\Standards-Global\MicroStation\Seed\3D-
Seed_CDOT.dgn 

2.  <D> The Models button on the MicroStation Primary toolbar. This displays the Models 
dialog box.

3. On the Models dialog box, <D> the Edit Model Properties button. This displays the 
Model Properties dialog box.

4. Set the Annotation Scale to 1” = 50’ using the drop down menu.

5. <D> OK. This dismisses the Model Properties dialog box.

6. <D> Yes on the message window that is displayed. This has no effect because the drawing 
is empty.

7. Close the Models dialog box.

8. From the MicroStation menu bar, select File > Save Settings.

Note: The changes to the seed file only last until the computer is logged off. At the next 
log in, the settings revert back their original state. The sheets created from the seed 
file maintain the changes.
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The same setting made above must also be made in the dgn file that will contain the profile 
information. The following steps remove the data from the previous lab and update the model 
properties and InRoads scale factors for 50 scale sheets.

9. Open the C:\Projects\12345\Design\Drawings\Reference Files\12345DES_Prof.dgn file.

10. Select File > Save As from the MicroStation menu bar. Navigate to: 
C:\Projects\12345\Design\Drawings\Reference Files\

11. Key in 12345DES_Prof_50Scale.dgn for the file name.

12. <D> Save.

13. Delete all of the data in the dgn file.

14. Repeat steps 2 through 8 above.

The dgn files are ready for the new scale. Next the InRoads settings are changed for 50 
scale.

15. From the InRoads menu bar, select Tools > Options and <D> the Factors tab and set the 
scale factors to 50. This can also be done from the Global Scale Factors dialog box.

16. <D> Apply and then <D> Close to dismiss the dialog box used.

17. Display the Plan and Profile Generator dialog box.

18. <D> the Main tab.

19. <D> the Preferences button. This displays the Preferences dialog box.

20. From the Preferences dialog box, highlight 50 Scale P&P (1x Vert). 

21. <D> Load.

22. <D> Close. This dismisses the Preferences dialog box.

Except for the Host File name, the user defined settings are still active and are used for this 
lab. To set the Host File name:

23. <D> the Sheet Layout tab.
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24. <D> in the Host File field, then <D> the  button. This displays the Save As dialog box.

25.  In the Save As dialog box, navigate to the C:\Projects\12345\Design\Drawings\ folder.

26. In the File Name field, key in 12345DES_PnP_50Scale.dgn.

27. <D> the Save button. This dismisses the Save As dialog box and adds the file name to the 
Host file field.

28. <D> the Apply button.

29. In the “Do you want to regenerate Plan Views?” message box, <D> Yes.

30. In the “Do you want to regenerate Profile Views?” message box, <D> Yes.

31. <D> in the MicroStation view window.

Nine 50 scale sheets are created. Follow the steps below to check that the correct annotation 
scale was used.

32. <D> The Models button on the MicroStation Primary toolbar. This displays the Models 
dialog box.

33. On the Models dialog box, <D> the Edit Model Properties button. The Model 
Properties dialog looks like the illustration below.

34. <D> Cancel to dismiss the Model Properties dialog box.

35. Close the Models dialog box.

Lab 17.3 - Edit Sheet Extents

After examining the sheets created in the last lab, the intersection on sheet 4 should be centered 
on the sheet. In this lab, the sheet extents are changed to center the intersection.

First, view sheet 4 to determine the amount of shift required.

1. <D> the Sheet Index tab.

2. Highlight sheet 4 from the Sheet Index list.
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3. <D> the Show Sheet button.

Examining sheet 4 shifting two stations (200 feet) to the left centers the intersection.
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4. Open the C:\Projects\12345\Design\Drawing\Reference Files\12345DES_Prof.dgn file.

5. Delete the previously displayed profiles.

Plan and Profile Generator can be used to specify the station extents of any sheet.   Here, sheet 
4 is adjusted to center the intersection and the other sheets will automatically be changed to 
match. The steps below update the station extents on sheet 4.

6. <D> the Main tab.

7. Toggle on Use Plan Views. 

8. Highlight sheet 4 in the Plan Views list.

9. <D> the Edit button. This displays the Edit Plan View dialog box.

10. In the Edit Plan View dialog box, key in 222+00.00 for the Start station.

11. Key in 229+00.00 for the Stop station.
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12. <D> Apply. This displays the Adjust Plan Views dialog box.

The next steps update the remaining sheets to match the changes made to sheet 4.

13. In the Adjust Plan Views dialog box, toggle on Adjust all views to maintain view 
lengths.

14. <D> the OK button.

15. <D> Yes on the “Update view names in corresponding sheets?” Message box.
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16. In the Edit Plan View dialog box, <D> Close.

Reducing the start station by 2, shifts the intersection to the middle of the sheet. Toggling on 
Adjust all views to maintain view lengths, resets the stations on the remaining sheets.

Finally, the steps below regenerate the sheets.

17. On the Plan and Profile Generator dialog box, <D> Apply.

18. <D> Yes in the, “Do you want to regenerate Profile Views?” message.

19. <D> in the MicroStation view window.

20. After processing is complete, examine sheet 4 as described at the first of the lab. The 
illustration below shows how the sheet looks.
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Lab 17.4 - Moving Reference Files Within the Sheet Border

After adjusting the sheets in the last lab, the first sheet has only 400 feet of data. The data is 
aligned with the left margin of the sheet border, but should be aligned with the right margin.

This lab demonstrates how to shift the data within the sheet border.

1. Examine sheet 1, as described at the first of the lab. The illustration below shows sheet 1. 
The reference files for the plan and profile need to be shifted 300 feet or 6” (paper scale) to 
the right.

 

2. On the Plan and Profile Generator’s Sheet Index tab, highlight sheet 1 in the Sheet Index 
list.

3. In the Sheet Views list, highlight sheet 1 Plan.
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4. <D> Edit. This displays the Edit Sheet View dialog box.

5. In the Anchor X field, key in 7.75.

6. <D> OK. This dismisses the Edit Sheet View dialog box.

7. In the Sheet Views list, highlight sheet 1 Profile.

8. <D> Edit. This displays the Edit Sheet View dialog box.

9. In the Anchor X field, key in 7.75.
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10. <D> OK.

11. <D> the Regenerate Sheet button.

12. <D> Yes on the message box that is displayed.
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The sheet now looks like the illustration below.

Lab 17.5 - Adding a Model File to a Single Sheet

Many of the specialty groups create data that is included on the plan sheets. However, much of 
this information applies to a localized area and is contained on one or two sheets in the set (a 
bridge or intersection, for example). 

This lab demonstrates how to attach a Model File to a single P&P Sheet. A traffic signal plan is 
added to Sheet 4.
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1. Examine sheet 4, as described at the first of the lab. The illustration below shows sheet 4.

Additional models are added from the Edit options on the Main tab of the Plan and Profile 
Generator dialog box. The steps below illustrate this process.

2. <D> the Main tab.

3. Highlight sheet 4 in the Plan Views list.
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4. <D> the Edit button. This displays the Edit Plan View dialog box.

5. In the Edit Plan Views dialog box, <D> the Model Files button.

6. In the Open Model File dialog box, navigate to 
C:\Projects\12345\Traffic_ITS\Drawings\Reference_Files.

7. Highlight the 12345Signal01.dgn file.

8. <D> Open.

9. Back in the Edit Plan Views dialog box, <D> Apply.
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This change only occurs on sheet 4.   Therefore. there is no need to update the other sheets.

10. <D> No in the message box that is displayed.

11. <D> Close to dismiss the Edit Plan View dialog box.

Since the added model file only affects on sheet (sheet 4), there is no need to generate a new 
complete set. Instead, only sheet 4 is updated. The steps below are used to update the sheet. 

12. In the Plan and Profile Generator dialog box, <D> the Sheet Index tab.

13. In the Sheet Views list, highlight sheet 4.

14. <D> the Regenerate Sheet button.
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15. <D> Yes on the message box that is displayed.

The sheet now looks like the illustration below.

16. Close the Plan and Profile Generator dialog box.
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17. <D> Yes on the message box that is displayed. Navigate to C:\Projects\12345\Design\ 
InRoads\ and name it 12345DES_50Scale.vdf.

18.  Save all of the data files and Close InRoads.

19. Close MicroStation.

Chapter Summary:

 In Lab 17.1 -Creating 100 Scale P and P Sheets the input data for the initial 100 scale Plan 
and Profile Generator run was described

 In Lab 17.2 -Creating 50 Scale P and P Sheets the annotation scale in the seed files was 
changed for 50 scale sheets along with the InRoads scale factors and the Plan and Profile 
Generator settings. Then a new set of sheets was generated

 In Lab 17.3 -Edit Sheet Extents the sheet extents for the 50 scale plans were modified to 
center the intersection and the sheets were regenerated

 In Lab 17.4 -Moving Reference Files Within the Sheet Border the reference files (plan and 
profile) were moved within the sheet border to the right margin

 In Lab 17.5 -Adding a Model File to a Single Sheet a traffic signal plan model file was 
added to sheet 4 only


